Create Plan 9 Raspberry PI SD card

Kare Nuorteva
Blog by Kare Nuorteva
2 min readNov 16, 2016

--

Start installation process by downloading the latest disk image from https://github.com/sirnewton01/rpi-9front/releases

Insert SD card and inspect available disks and find the correct path to the disk. In my case it is /dev/disk1.

% diskutil list
/dev/disk0 (internal, physical):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *160.0 GB disk0
1: EFI EFI 209.7 MB disk0s1
2: Apple_HFS OS X 159.2 GB disk0s2
3: Apple_Boot Recovery HD 650.0 MB disk0s3
/dev/disk1 (internal, physical):
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *7.9 GB disk1
1: DOS_FAT_32 9PI BOOT 61.9 MB disk1s1
2: 0x39 1.9 GB disk1s2

In order to write the image to the SD card you must unmount the disk first.

% diskutil unmountDisk /dev/disk1
Unmount of all volumes on disk1 was successful

Then unzip the downloaded image.

% bunzip2 Downloads/9front-pi.img.bz2

Now write the image to the disk with the following command. Notice that I have replaced /dev/disk1 with /dev/rdisk1. This will speed up the write process as discussed at superuser.com.

You can hit ctrl+t to view the status of the dd write process.

% sudo dd bs=1m if=Downloads/9front-pi.img of=/dev/rdisk1
Password:
load: 0.97 cmd: dd 2419 uninterruptible 0.00u 0.57s
566+0 records in
565+0 records out
592445440 bytes transferred in 100.873418 secs (5873157 bytes/sec)

Finally I had to unmount the 9fat partition with the command:

% sudo unmount /dev/disk1s1

And you are done. Happy Raspberry PI and Plan 9 hacking!

--

--